Delays sending emails

Incident Report for Mixmax

Postmortem


Resolved

This incident has been resolved.
Posted Sep 25, 2020 - 01:46 UTC

Monitoring

Google latency have returned to normal. There are no longer delays on sequences and sending messages.
Posted Sep 25, 2020 - 01:36 UTC

Investigating

We are currently investigating this issue. Increased latency from Gmail and Google Calendar APIs. Sequence messages, sending messages, scheduling calendar events are seeing increased error rates and may have delays due to errors from Google.
Posted Sep 25, 2020 - 01:24 UTC
This incident affected: Sending emails in Gmail/Inbox.