Mixmax Paid Features Were Temporarily Unavailable

Incident Report for Mixmax

Postmortem

Post-Incident Update: Mixmax Paid Features Were Temporarily Unavailable (June 27–29, 2026)

What happened

From June 27 to June 29, 2026, some customers were unable to access certain paid features. This included creating and activating sequences, using Meeting Copilot for specific meetings, and using other features that require a paid plan.

Root cause

Our system that verifies account access to paid features became overwhelmed. As a result, some paid accounts were temporarily classified as free accounts, blocking access to paid features.

How we resolved it

We addressed the issue by increasing the capacity of the affected system and alleviating the extra load that was contributing to the problem. All affected features are now functioning normally.

What we’re doing to prevent this from happening again

We have reviewed the incident and are making the following improvements:

  1. Increasing system capacity to accommodate higher demand.
  2. Enhancing system efficiency by streamlining unnecessary checks.
  3. Upgrading our monitoring systems to detect issues more quickly.
  4. Implementing stronger safeguards to prevent similar problems in the future.

We sincerely apologize for the disruption this has caused and appreciate your patience while we resolve it. If you are still experiencing any issues related to this incident, please reach out to our support team via support@mixmax.com.

Posted Jun 30, 2026 - 22:36 UTC

Resolved

This incident has been resolved.
Posted Jun 29, 2026 - 16:51 UTC

Update

System is back to normal operation.
Posted Jun 29, 2026 - 16:04 UTC

Monitoring

A new fix is improving the situation. We're continuing to actively monitor the issue.
Posted Jun 29, 2026 - 15:11 UTC

Update

The applied fix was not effective. We're continuing to research the problem.
Posted Jun 29, 2026 - 14:27 UTC

Update

The fix has been delivered and the system is recovering. We're continuing active monitoring of the problem.
Posted Jun 29, 2026 - 14:02 UTC

Identified

Some users are experiencing issues getting access to the features they are subscribed for -- their accounts behaving as free user accounts.

We have identified the cause and we're delivering a fix.
Posted Jun 29, 2026 - 13:57 UTC
This incident affected: Sending emails in Gmail/Inbox, Web app, API, Rules, and Sidebar.