The dashboard is either slow or not loading. Emails sent with Mixmax may be delayed or fail to send.

Incident Report for Mixmax

Update

Our service is currently unavailable due to the ongoing widespread outage with Amazon AWS. Mixmax sending is temporarily turned off so that emails you send in Gmail continue to deliver normally. We are monitoring the situation with AWS and working diligently to resolve. Thanks for your patience.
Posted Oct 20, 2025 - 18:57 UTC

Update

Our service is currently unavailable due to an outage with Amazon AWS. Sending emails with Mixmax is temporarily disabled to not impact sending emails through Gmail. We are working diligently to resolve this issue as quickly as possible. Thank you for your patience.
Posted Oct 20, 2025 - 18:22 UTC

Update

Our service is currently unavailable due to an outage with Amazon AWS. We are working diligently to resolve this issue as quickly as possible. Thank you for your patience.
Posted Oct 20, 2025 - 14:18 UTC

Update

Our service is currently unavailable due to an outage with Amazon AWS. We are working diligently to resolve this issue as quickly as possible. Thank you for your patience.
Posted Oct 20, 2025 - 14:17 UTC

Investigating

We are currently investigating this issue.
Posted Oct 20, 2025 - 14:03 UTC
This incident affects: Web app.