Delay in Email Sending
Incident Report for Mixmax
Resolved
Google has addressed the issue on their side. All delays to message sending have been resolved.
Posted Dec 14, 2023 - 20:09 UTC
Investigating
Some users may be experiencing delayed sending of messages and we are actively investigating.
Posted Dec 14, 2023 - 19:44 UTC
This incident affected: Sending emails in Gmail/Inbox.