- Increased latency sending emails due to Gmail API delays – Incident details

All systems operational

Increased latency sending emails due to Gmail API delays

Resolved
Degraded performance
Started over 6 years agoLasted 39 minutes

Affected

Sending emails in Gmail/Inbox

Operational from 3:07 PM to 3:07 PM, Degraded performance from 3:07 PM to 3:46 PM

Updates
  • Resolved
    UTC
    Resolved

    This incident has been resolved.

  • Monitoring
    UTC
    Monitoring

    Latency has returned to normal levels on Google's end. We're monitoring their fix.

  • Identified
    UTC
    Identified

    For some users, sending email from Gmail has high latency, both with and without Mixmax. Sequences and rules are still sending, albeit with delays. Google has acknowledged issues with Google Cloud https://status.cloud.google.com/incident/zall/20005 which we believe are causing downstream issues with Gmail. We're monitoring for a fix on their end.