- Increased latency retrieving Salesforce data – Incident details

All systems operational

Increased latency retrieving Salesforce data

Resolved
Degraded performance
Started over 6 years agoLasted about 17 hours

Affected

Sending emails in Gmail/Inbox

Operational from 12:00 AM to 7:00 AM, Degraded performance from 7:00 AM to 5:21 PM

Rules

Operational from 12:00 AM to 7:00 AM, Degraded performance from 7:00 AM to 5:21 PM

Updates
  • Resolved
    UTC
    Resolved

    Delayed rule processing has caught up, and all systems are fully operational.

  • Update
    UTC
    Update

    Processing of delayed rules is still ongoing. All other delayed processing has caught up, and our systems continue to be fully operational.

  • Monitoring
    UTC
    Monitoring

    We've implemented a fix which resolves the latency issues, and are monitoring while our systems process delayed jobs. No data has been lost.

  • Update
    UTC
    Update

    We're continuing to work with our third-party provider to remediate the issue.

  • Identified
    UTC
    Identified

    Some customers are experiencing delays when using functionality that retrieves data from Salesforce. We have traced this issue to a bug in third-party software, and are actively pursuing remediation.