- Unable to load https://mixmax.com – Incident details
All systems operational
Unable to load https://mixmax.com
Resolved
Degraded performance
Started over 5 years agoMarch 25, 2021Lasted about 2 hours2:554:44 PMUTC
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Monitoring
UTC
Monitoring
UTC
A fix has been implemented and we are monitoring the results.
Investigating
UTC
Investigating
UTC
The Mixmax homepage does not currently load when accessed at https://mixmax.com. It can however be accessed at https://www.mixmax.com. There is no impact on Mixmax product components (e.g. rules, sending emails, the API).