- Email sending delayed – Incident details

All systems operational

Email sending delayed

Resolved
Degraded performance
Started over 4 years agoLasted about 14 hours

Affected

Sending emails in Gmail/Inbox

Degraded performance from 3:55 PM to 6:07 AM

Updates
  • Resolved
    UTC
    Resolved

    This incident has been resolved.

  • Update
    UTC
    Update

    Our systems have recovered, and we're monitoring as we work through the backlog of events that built up during the outage.

  • Update
    UTC
    Update

    To mitigate delays due to the outage, we’ve switched customer emails to send directly through Gmail (not Mixmax.) During this time, you won't have access to Mixmax features in your compose window like saved templates and enhancements. Thanks for your patience as we work through this outage.

  • Monitoring
    UTC
    Monitoring

    We've fixed the delay in sending emails, but the underlying failures with our hosting provider are ongoing so we will continue to monitor and address any further issues that arise.

  • Identified
    UTC
    Identified

    Emails sent via Gmail are currently delayed due to a widespread outage with our hosting provider AWS affecting many companies. We're working to resolve this as quickly as possible.