- Delay in Email Sending – Incident details

All systems operational

Delay in Email Sending

Resolved
Degraded performance
Started over 2 years agoLasted 25 minutes

Affected

Sending emails in Gmail/Inbox

Operational from 7:44 PM to 7:44 PM, Degraded performance from 7:44 PM to 8:09 PM

Updates
  • Resolved
    UTC
    Resolved

    Google has addressed the issue on their side. All delays to message sending have been resolved.

  • Investigating
    UTC
    Investigating

    Some users may be experiencing delayed sending of messages and we are actively investigating.