Email enhancements added to Templates and Sequences are missing.

Incident Report for Mixmax

Postmortem

Incident Summary:

On November 5, 2025, a software update introduced a bug that prevented email enhancements from being saved in Templates and Sequences. We rolled back the update, which resolved the issue.

Timeline:

  • 5:00 AM PST: A problematic update has been released.
  • 10:35 AM PST: Update rolled back.

Outage duration: ~5 hours.

Impact:

Users who tried to save Templates or Sequences with email enhancements (such as Preview Links, Share Availability, CTA Buttons, Polls, etc.) between 5:00 AM and 10:35 AM PST lost their changes. Templates or Sequences with email enhancements saved outside this timeframe or without enhancements were not affected.

If you need further assistance, please reach out to support at support@mixmax.com.

Thank you for your understanding.

Posted Nov 05, 2025 - 18:52 UTC

Resolved

This incident has been resolved.
Posted Nov 05, 2025 - 18:51 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 05, 2025 - 18:41 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 05, 2025 - 18:36 UTC

Update

Affected email enhancements include Link Previews, Share Availability, CTA Buttons, etc.
Posted Nov 05, 2025 - 18:18 UTC

Investigating

We are currently investigating this issue.
Posted Nov 05, 2025 - 18:16 UTC
This incident affected: Web app.