We’re aware of a widespread Microsoft Azure outage that may be affecting Mixmax functionality for Outlook users. Our team is monitoring the situation and working to minimize any impact.

Incident Report for Mixmax

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 21:18 UTC

Identified

The ongoing Microsoft Azure outage is impacting Mixmax functionality for Outlook users. Our team is closely monitoring the situation and working to minimize any adverse effects.
Posted Oct 29, 2025 - 18:03 UTC

Investigating

We are currently investigating this issue.
Posted Oct 29, 2025 - 18:00 UTC
This incident affected: Web app.