- Delays in email sending – Incident details
Get updates
Email
Slack
Google Chat
Webhook
API
Get updates
All systems operational
Delays in email sending
Resolved
Degraded performance
Started almost 6 years ago
October 08, 2020
Lasted less than a minute
1:00
1:00 PM
UTC
Updates
Resolved
October 08, 2020 at 1:00 PM
UTC
Resolved
October 08, 2020 at 1:00 PM
UTC
Some emails may have experienced up to a three and a half minute delay in sending.
UTC
UTC
UTC