Started over 5 years agoFebruary 24, 2021Lasted about 3 hours10:29 PMFebruary 25, 20211:01 AMUTC
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Monitoring
UTC
Monitoring
UTC
Our fix has been implemented and we're now monitoring.
Identified
UTC
Identified
UTC
We've identified the root cause and fix is being implemented for this issue.
Investigating
UTC
Investigating
UTC
Our sequence processing functionality is currently degraded. Users may not be able to add new recipients to sequences or pause or resume recipients, and we are currently not processing sequence stages or sending sequence emails.