- Email tracking is either delayed or not getting captured. – Incident details

All systems operational

Email tracking is either delayed or not getting captured.

Resolved
Degraded performance
Started about 1 year agoLasted 31 minutes

Affected

Sending emails in Gmail/Inbox

Operational from 10:04 PM to 10:04 PM, Degraded performance from 10:04 PM to 10:36 PM

Updates
  • Update
    UTC
    Update

    Between 8:25 a.m. PDT and 3:05 p.m. PDT on July 1, 2025, a regression introduced in a recent software release caused our email tracking system to stop functioning. As a result, any email opens during this period was not tracked. Email open events during the outage window were not recorded, and this data cannot be recovered. All other features remained operational, and no other data was affected. Our team identified the issue and rolled back an update that caused it by 3:05 p.m. PDT on July 1, restoring full email tracking functionality. For further questions or concerns, reach out to our support team at [support@mixmax.com](mailto:support@mixmax.com).

  • Resolved
    UTC
    Resolved

    This incident has been resolved.

  • Monitoring
    UTC
    Monitoring

    A fix has been implemented and we are monitoring the results.

  • Investigating
    UTC
    Investigating

    We are currently investigating this issue.