- We’re aware of a widespread Microsoft Azure outage that may be affecting Mixmax functionality for Outlook users. Our team is monitoring the situation and working to minimize any impact. – Incident details

All systems operational

We’re aware of a widespread Microsoft Azure outage that may be affecting Mixmax functionality for Outlook users. Our team is monitoring the situation and working to minimize any impact.

Resolved
Partial outage
Started 9 months agoLasted about 3 hours

Affected

Web app

Operational from 6:00 PM to 6:00 PM, Partial outage from 6:00 PM to 9:18 PM

Updates
  • Resolved
    UTC
    Resolved

    This incident has been resolved.

  • Identified
    UTC
    Identified

    The ongoing Microsoft Azure outage is impacting Mixmax functionality for Outlook users. Our team is closely monitoring the situation and working to minimize any adverse effects.

  • Investigating
    UTC
    Investigating

    We are currently investigating this issue.