- Email enhancements added to Templates and Sequences are missing. – Incident details

All systems operational

Email enhancements added to Templates and Sequences are missing.

Resolved
Degraded performance
Started 8 months agoLasted 35 minutes

Affected

Web app

Operational from 6:16 PM to 6:16 PM, Degraded performance from 6:16 PM to 6:51 PM

Updates
  • Update
    UTC
    Update

    **Incident Summary:** On November 5, 2025, a software update introduced a bug that prevented email enhancements from being saved in Templates and Sequences. We rolled back the update, which resolved the issue. **Timeline:** * 5:00 AM PST: A problematic update has been released. * 10:35 AM PST: Update rolled back. Outage duration: ~5 hours. **Impact:** Users who tried to save Templates or Sequences with email enhancements \(such as Preview Links, Share Availability, CTA Buttons, Polls, etc.\) between 5:00 AM and 10:35 AM PST lost their changes. Templates or Sequences with email enhancements saved outside this timeframe or without enhancements were not affected. If you need further assistance, please reach out to support at [support@mixmax.com](mailto:support@mixmax.com). Thank you for your understanding.

  • Resolved
    UTC
    Resolved

    This incident has been resolved.

  • Monitoring
    UTC
    Monitoring

    A fix has been implemented and we are monitoring the results.

  • Identified
    UTC
    Identified

    The issue has been identified and a fix is being implemented.

  • Update
    UTC
    Update

    Affected email enhancements include Link Previews, Share Availability, CTA Buttons, etc.

  • Investigating
    UTC
    Investigating

    We are currently investigating this issue.